overheating rincon - Honda Rincon Forum : RinconRiders Honda Rincon Forums


Reply
 
LinkBack Thread Tools
Old 04-02-2012, 08:42 PM   #1 (permalink)
Junior Member
 
Join Date: Apr 2012
Location: CYPRESS TX
Posts: 29
Unhappy overheating rincon

Ok well i did all the advice i was gave clean bettwen the radiator and oil cooler and check all the other stuff and my rincon still over heated well sucks to say that it shut off and when i turn it back on it shuts off it lost all power does this mean its dead
marcosevelyn07 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 04-02-2012, 09:57 PM   #2 (permalink)
Member
 
Brandon2011Rincon's Avatar
 
Join Date: Feb 2012
Location: Peterborough ON. Canada
Posts: 737
Default

Was your fan coming on?!
__________________
Kimpex Front bumper, 26" Interco Swamplite reptiles, Warn Winch, stealth snorkel, Vents ran to pod, Exhaust tip, 2" Lift, Garmin GPS, and a smile ear to ear!
Brandon2011Rincon is offline   Reply With Quote
Old 04-02-2012, 10:07 PM   #3 (permalink)
Junior Member
 
Join Date: Apr 2012
Location: CYPRESS TX
Posts: 29
Default

Yea its actually hooked on directly i don't have a clue why it over heats but now i actually think i killed it because it has no power and it shuts of after a couple of seconds
marcosevelyn07 is offline   Reply With Quote
Old 04-03-2012, 10:34 AM   #4 (permalink)
Senior Member
 
YellowCJ's Avatar
 
Join Date: Aug 2004
Location: Maine
Posts: 2,263
Default

Sounds like your not getting any cooland circulation, possibly air pocket, blockage or bad water pump. I would focus on the coolant system at this point.
__________________
Impeach The US Government!
Why, because it no longer stands for Americans!

Government is not the answer to our problems, government is the problem!

Taxation is the antithesis of freedom.

2004 Yellow Honda Rincon with Warn 2500 winch, Moose cargo rack, Moose gun rack, Moose 60" Snow Plow, Honda trailer hitch, Yuasa YTX 20-BS Battery.
2006 Jeep Grand Cherokee Limited-5.7L V8 HEMI, Tilt utility trailer with Fastrap Tiedowns.
2007 Honda Shadow Aero 750, 2010 Massey Ferguson GC2410.
YellowCJ is offline   Reply With Quote
Old 04-03-2012, 01:59 PM   #5 (permalink)
Member
 
Join Date: Feb 2011
Location: Ragley, Louisiana
Posts: 41
Default

Just a thought..... Did you blow a head gasket? If you do fix it from cutting off, I would relocate the rad! Mine is done with wild boar atv relocate kit! Works great and was 189.00! Comes with all hardware needed too.
Have you flushed the rad out? Check you water pump vent line it could be clogged. I have heard of that happening, and frying the water pump! Hope you fix the prob tho! Good luck!
rookie2006hhrc is offline   Reply With Quote
Old 04-03-2012, 06:35 PM   #6 (permalink)
Junior Member
 
Join Date: Apr 2012
Location: CYPRESS TX
Posts: 29
Default

Sounds like a dumb ?? But how can i know if i blew a gasket
marcosevelyn07 is offline   Reply With Quote
Old 04-03-2012, 07:56 PM   #7 (permalink)
Member
 
Brandon2011Rincon's Avatar
 
Join Date: Feb 2012
Location: Peterborough ON. Canada
Posts: 737
Default

Check your oil and see if it's cloudy at all. If the gasket is gone you'd have coolant mixed in with your oil. I believe you would have a whitish cloudy residue on the underside of our oil fill cap...
__________________
Kimpex Front bumper, 26" Interco Swamplite reptiles, Warn Winch, stealth snorkel, Vents ran to pod, Exhaust tip, 2" Lift, Garmin GPS, and a smile ear to ear!
Brandon2011Rincon is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply Active Topics

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 09:31 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.