03 650 stuck in first or second gear and no speedometer. - Page 2 - Honda Rincon Forum : RinconRiders Honda Rincon Forums
Reply
 
LinkBack Thread Tools
post #11 of 12 (permalink) Old 05-12-2019, 10:58 PM Thread Starter
Junior Member
 
Eric Williams's Avatar
 
Join Date: Dec 2018
Posts: 11
I also go this loud tapping noise at about 1/4 throttle. Somebody told me it could be cam bearing holder, piston slap or a rod bearing is done. What to y’all think? Here’s the video I took of it. https://youtu.be/RjHqRLpMWUI

Can't feast on the past, gotta eat what's in my path
I'm not blind with these blinders on, just see what's ahead of me
No fear of my enemies, I'm only scared of me
Eric Williams is offline  
Sponsored Links
Advertisement
 
post #12 of 12 (permalink) Old 05-12-2019, 11:00 PM Thread Starter
Junior Member
 
Eric Williams's Avatar
 
Join Date: Dec 2018
Posts: 11
The sound is definitely coming from the top end

Can't feast on the past, gotta eat what's in my path
I'm not blind with these blinders on, just see what's ahead of me
No fear of my enemies, I'm only scared of me
Eric Williams is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Honda Rincon Forum : RinconRiders Honda Rincon Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome