Honda Rincon Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
167 Posts
Discussion Starter · #1 ·
I have been reading these great posts on this fantastic website. I have an 03 Rincon and had to change the waterpump at 600 miles. The dealer said that the new pump has a bigger breather hose and is now facing downwards to prevent clogging with mud. I've looked at it and they are right. I am wondering if anyone has had any kind of problems with the NEW style pump.

Rob
 

·
Registered
Joined
·
29 Posts
Hey Omega

I too had to get the water pump changed on my 04 because of the same problem. Just a heads up, I would spread the oil cooler/rad apart to help with air flow and the ablity to clean the mud out between them or you might have overheating problems down the road. After this change the bike has not had a problem since. It seems that the rincon will overheat if the rad isn't well looked after.


T-Bone
 

·
Registered
Joined
·
224 Posts
I just had my water pump replaced on my 2003 at 1200 miles. Now I notice that they put my old breather hose back on. The dealer is clueless and says that is what Honda sent them. I am going to the dealer and showing them the difference in hoses with the 2005 on their showroom floor. They are so ignorant they won't even check themselves. Their attitude is, if it breaks, bring it in. Also, since the waterpump change, I have noticed that my fan comes on more than usual. It stays on during slow speed riding around 10 mph and with air temps around 65 degrees. Does anyone have any comments on their fan operation? Thanks
 

·
Registered
Joined
·
167 Posts
Discussion Starter · #4 ·
thanks...............Omega
 

·
Registered
Joined
·
25 Posts
mine dont work now so i wouldnt know

but i had my waterpump replaced and they put the stock hose back on mine so im gonna get another one ordered

by the way my hose kept fallin off so i put a hose clamp on it
 

·
Registered
Joined
·
224 Posts
If anyone does have the water pump replaced, insist on the updated hose design that is on the 2005 models. I took it back to the dealer and they were understanding and ordered the correct hose. I am still not sure if that new hose design is going to stop the problem. Has anyone with the new hose design had water pump problems? Thanks
 
1 - 6 of 6 Posts
Top