Honda Rincon Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Just purchased a used 2003 Rincon, so far so good, everything seems to be working just fine. Only issue to date is that when going from neutral to reverse most of the time it clicks for a second or two until it engages. Anyone have any ideas or suggestions?
Thanks, Rob...
 

·
Premium Member
Joined
·
3,621 Posts
RobH welcome to the Forum.

My .02 would be the linkage needs an adjustment.

Do you have a service manual?
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
Ordered service manual last week, should be in this week. I took a quick look at the linkage this past weekend, it didn't appear to be adjustable however I know it should be and it was only a quick look, will check out service manual when it arrives. Thought maybe someone else on the forum had dealt with the same issue and would have the quick solution. Appreciate your response. Really enjoying this web site, there seems to be a wealth of information contained in the posts.
Thanks, RobH
 

·
Registered
Joined
·
151 Posts
Mine will do what you describe if it is not pushed down when brought back..... It seems it is operator error on my end.... doing a quick half shift..... check that out....

Brian
 

·
Registered
Joined
·
121 Posts
The adjustment linkage is under the gas tank. You will have to remove the
right and left sides, as well, as the gas tank, and white plastic heat sheild
that is under the gas tank. for more info search for "Transmission clunk"
under Drivetrain


TrailBoss
 
1 - 5 of 5 Posts
Top