Honda Rincon Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
93 Posts
Discussion Starter · #1 ·
Has anyone noticed that when you ride in ESP Mode all the way to 3rd gear, then try to downshift using the down arrow it doesn't work. The ESP gear selections on the display starts blinking. If I put the Trans selector on Auto it still doesn't correct the problem. But if I kill the engine and restarted everything seems to work fine. I only get this problem in ESP Mode and it's intermitten. Not sure if it's moisture in the electrical or need to take the machine to the dealer. Help.
 

·
Registered
Joined
·
29 Posts
How many times does it blink ? Post your blinking #. Also your ECM may have dirt in it, it is behind the battery box. Clean the ECM connnection and put dielectric grease in it and you should fix your problem. Steven
 

·
Registered
Joined
·
6 Posts
I had a very similar issue. My problem would happen after shutting the Rincon down and then trying to start it back up soon after. I pulled the ECM and cleaned it out (even though the connection is very solid and not prone to dirt), but it had to be replaced in the end. Take it in before your warranty runs out!!!
 

·
Registered
Joined
·
93 Posts
Discussion Starter · #4 ·
Thanks for the info. I put dielectric grease and so far there hasn't been any problems. If it comes back I'm definitely going to the dealer. I will post any actions i might take in the future.
 

·
Registered
Joined
·
338 Posts
i had water in one of the connectors once which thru it in the limp mode,cleaned it out with no more problems,that was over 2000 miles ago..it maybe flashing you a code so you can diganois what circuit is giving you problems..the service manual is a big help with this..
 

·
Registered
Joined
·
2 Posts
I bought a 04 green rincon 3 weeks ago. Went riding a few times and now the esp is blinking. 3 times if that helps. I am about to pull and clean the ecm Any info on the code (3) thanks
 
1 - 7 of 7 Posts
Top