Honda Rincon Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
It usually starts up fine and still did today . I went for a ride the gas meter blinks and don’t show the actual amount of gas , also learned that my quad don’t like reverse it shut off today after backing it up , then I put it in neutral and it took a good minute for it to start and then it died again and then started so I proceeded to put it in drive and it didn’t go no where until I switched from auto to manual. Then switched back to auto . Any tips ? Just got it 2 days ago .
Haven’t roughed it out
 

·
Super Moderator
Joined
·
6,621 Posts
The sending unit in your gas tank has probably worn out. Replace it and the blinking fuel gauge will stop.
Since you just got it, at the least do an oil and filter change and check the rad for debris and that it is full of antifreeze.

Correct oil for wet clutches, and being full is important on this ATV, as low oil volume will allow the clutches to slip. Warm your engine, then shut it off and remove the dipstick, wipe it off and insert it, no need to screw it in just insert and remove to inspect the oil volume. Should be at the top mark.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
The sending unit in your gas tank has probably worn out. Replace it and the blinking fuel gauge will stop.
Since you just got it, at the least do an oil and filter change and check the rad for debris and that it is full of antifreeze.

Correct oil for wet clutches, and being full is important on this ATV, as low oil volume will allow the clutches to slip. Warm your engine, then shut it off and remove the dipstick, wipe it off and insert it, no need to screw it in just insert and remove to inspect the oil volume. Should be at the top mark.
Thank you! Will be looking at it in the am !!
 

·
Registered
Joined
·
12 Posts
please check your battery voltage while its off then again while it running and let me know the readings. you should be seeing around 12.6 volts DC and at least 14.3 volts DC. It seems like you are having several issues related to electric.
 
1 - 4 of 4 Posts
Top