Honda Rincon Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Okay so I Just bought a 2013 Rincon 680 that supposedly had a transmission issue. The bike shifts into gear on the display, but will not turn the tires in forward reverse, auto or esp. So I figured while I wait for the service manual to get here, I’d do an oil change in the meantime..so I empty the oil and it looks decent. Then I open up the filter and it’s bone-dry. Not a drop of oil on it. Any ideas? Bad oil pump? Anyone else deal with this type of thing? Thanks in advance for the help guys.
 

·
Premium Member
Joined
·
5,764 Posts
Very possible to be oil pump or oil pump chain issue. You need to do an oil pressure check.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
Very possible to be oil pump or oil pump chain issue. You need to do an oil pressure check.
Okay, where and how do I check the pressure(s)? I’ve only had the bike for three days and I have all the plastics and racks taken off. I’m preparing for the worst if I’m going to have to pull this motor to mess with this oil pump -.0
 

·
Registered
Joined
·
4 Posts
Discussion Starter #4
Edit: just found a post about transmission troubleshooting with some attachments 👍🏼 I’ll try to post again when I figure it out
 

·
Premium Member
Joined
·
467 Posts
If it did throw the oil pump drive chain, and it sounds like it did, obviously don’t run the engine any longer than needed to diagnose.

If the filter is bone dry though....
 
1 - 5 of 5 Posts
Top