Honda Rincon Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
314 Posts
Discussion Starter · #1 ·
Took it out for a slow cruise around the neighborhood and after about five miles it starting cutting out running about 15 mph. Took it home and checked everything obvious and even changed the plug. It will wind out tight in nuetral sitting still and idles just fine but it starts stumbling at speed over 1/4 throttle.

Any ideas?

Thanks,
Greg
 

·
Premium Member
Joined
·
1,963 Posts
I think it's an all plastic float isn't it?
 

·
Registered
Joined
·
314 Posts
Discussion Starter · #4 ·
Rob,

I will take a look at the float, hard to judge/reset without a gage. Why would it wind out well sitting still but not a speed because of a float?

Thanks,
Greg
 

·
Super Moderator
Joined
·
6,755 Posts
Park GT

Since you installed the jet kit, are you sure you tightened the white philips head screw to the click? (where the needle is installed) I would pull off the top of the carb (4 screws) and check the spring, needle and that white screw. I'll bet it came loose and is now just sitting in there loose.
Does your display blink at all when the Rincon is reving under load?

Oilcan
 

·
Registered
Joined
·
314 Posts
Discussion Starter · #6 ·
Oilcan,

Thanks for the idea. I did have it open and the needle is still firmly in place. Don't remember any blinking but I will check again. Tomorrow evening I will tear into the carb to see what I can find.

Thanks,
Greg
 

·
Registered
Joined
·
314 Posts
Discussion Starter · #9 ·
Thanks for the replies guys. Well I pulled the carb part way out and opened it top and bottom. Blew it out and cleaned with carb cleaner. Reassembled and ran some SeaFoam through the gas. Don't know what fixed it but it is back to normal.
 

·
Registered
Joined
·
409 Posts
One of the first things I did was install a fuel filter. Cheap investment and easy to do.
 
1 - 11 of 11 Posts
Top