Honda Rincon Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
This is the second display I'm having changed. Has anyone seen this problem?I belive it gets in from under the speedo head when water vapor comes off the radiator. The first display had 50 miles and this one only has 35.
 

·
Registered
Joined
·
322 Posts
Mine had to be changed once ( not gps ) but it only had a few miles on it. They put a new on on under warranty and so-far no more probs. That was a year or so ago.
 

·
Registered
Joined
·
10 Posts
I've noticed that on mine a couple of times, just a little condensation under the lens. I just thought it was from moving it from inside to out in the sun. Have you had any problems because of it??? I wasn't going to worry about it.
 

·
Registered
Joined
·
66 Posts
Mines had something in there it looks like water but it's never fogged up the glass at all. I don't really notice it unless the sun is shining on it.
 

·
Registered
Joined
·
224 Posts
I have noticed it too. I can see a little condensation then it dries up. Does not seem to affect operation. I probably should bring it to the dealer's attention.
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #7 ·
I had my new dislay put in and I think I've discovered the problem. The back of the display has 4 vent holes. I believe the steam from the engine and radiator after running thru a puddle is the culprit. I have plugged up all 4 holes with silacone sealer and lets see what happens. I don't see the need for them the unit dosent generate any heat. I'll report in a few weeks and let you know if it was a mistake.
 

·
Registered
Joined
·
85 Posts
Same thing as MeanGreenRincon for me!
 
1 - 8 of 8 Posts
Top